Notifications
Clear all

[Solved] Failed to install NDK/Caffe prerequisites

Page 1 / 2
 

Hight
(@hight)
Active Member
Joined: 2 years ago
Posts: 14
Topic starter  

Linux Host: Ubuntu 20.04.1, Linux 5.13 kernel

According 3.1.3 Software prerequisities installation, during the installaton of NDK/Caffe prerequsities "python3.x", the following errors occurred.

sudo apt-get update
sudo apt install build-essential
sudo apt-get install virtualenv
sudo apt-get install python3.x
stoped!

……

E:Failed to fetch http://cn.archive.ubuntu.com/ubuntu/pool/universe/p/python-xdo/python3-xdo_0.4-2_all.deb connection failed

E:Unabile to fetch some archives, maybe run apt-get update or try with --fix-missing?


I am not sure if the "sources.list" is causing this problem.

The sources.list is default.

BTW, the native compilation tools (such as build-essential) all can be installed successfully.

This topic was modified 10 months ago by Hight

   
Quote
Topic Tags
paulbuxton
(@paulbuxton)
Member Moderator
Joined: 11 months ago
Posts: 15
 

Hi

I am looking into this now. So far I haven't been able to reproduce it. 

It is possible this is a transient problem with the repository. Can you retry?

I am able to fetch the package manually using 

wget http://cn.archive.ubuntu.com/ubuntu/pool/universe/p/python-xdo/python3-xdo_0.4-2_all.deb

 

Are you able to fetch it in this way?

I see from your profile and the URL of the package that you are in China, I think we have sometimes seen issues with repositories not being accessible from machines in China. I am contacting some of our colleagues in China to see if they see this problem and if they have a workaround.

 

If you are still unable to run the command 

sudo apt-get install python3.x

 could you attach a copy of your /etc/apt/sources.list so that I can try and reproduce the problem here.

 

Thanks.

Paul


   
ReplyQuote
luispimo
(@luispimo)
Member Moderator
Joined: 3 years ago
Posts: 16
 

Hi @hight 

Apparently it seems an issue related to apt/sources.list.

It is possible that the source.list is corrupted.

You can try the following:

1. Remove the file: sudo rm /etc/apt/sources.list
2. Create an empty one: sudo touch /etc/apt/sources.list
3. Restore the default settings using "Software & Updates" tool (see attached image)

Regards

Luis


   
Memi reacted
ReplyQuote
Hight
(@hight)
Active Member
Joined: 2 years ago
Posts: 14
Topic starter  

@paulbuxton 

Hi,

I have changed sources.list (/etc/apt/sources.list). The problem about fetch has been resolved.

All packages can be installed successfully, including "native compilation tools","NDK/Caffe prerequisites","Tensorflow","Cross-compilation".

The sources.list I used in HOST is local source (By modify through vim). Also you can try to change it by the method of @luispimo

Regards,

Tao


   
RCWO reacted
ReplyQuote
Yasmine
(@yasmine)
New Member
Joined: 8 months ago
Posts: 2
 

Hello,

I am still having trouble with passing the TensorFlow to the CAFFE to IMG-NNVM conversion tests. Below is a screenshot  of the error I am getting.

Your help is truly appreciated.

Best Regards,

Yasmine Abu Adla


   
RCWO reacted
ReplyQuote
paulbuxton
(@paulbuxton)
Member Moderator
Joined: 11 months ago
Posts: 15
 

Hi,

That looks like caffe was not successfully installed during the setup process. The failure to install it is likely visible further up the console log. If you could either scroll up to show that, or run the installer capturing the console output to a file it would be helpful. You can do that using the tee command as shown below

devtools.run 2>&1 |tee /tmp/output.txt


   
RCWO reacted
ReplyQuote
Yasmine
(@yasmine)
New Member
Joined: 8 months ago
Posts: 2
 

@paulbuxton 

Hello,

Thank you for your reply.

Kindly find attached the output of the terminal when i attempt to install NDK prerequisites.

Best,

Yasmine


   
ReplyQuote
paulbuxton
(@paulbuxton)
Member Moderator
Joined: 11 months ago
Posts: 15
 

Hi, @yasmine. I don't see an attachment...


   
ReplyQuote
RCWO
 RCWO
(@rcwo)
Member Admin Registered
Joined: 3 years ago
Posts: 54
 

@paulbuxton @Yasmine

Try different file formats, the Forum system rejects some. I think JPEGs are OK. And .PNGs


   
ReplyQuote
paulbuxton
(@paulbuxton)
Member Moderator
Joined: 11 months ago
Posts: 15
 

What we actually want is a text file. The console output will be more than can easily fit onto a single screen and we cannot search an image for error strings.


   
ReplyQuote
RCWO
 RCWO
(@rcwo)
Member Admin Registered
Joined: 3 years ago
Posts: 54
 

Text files .txt are OK

@Jasmine  If you can't post, e-mail to [email protected]


   
ReplyQuote
Memi
 Memi
(@memi)
Active Member
Joined: 2 years ago
Posts: 12
 

W: Skipping acquire of configured file 'bionic-updates/main/dep11/Components-amd64.yml' as repository 'http://archive.ubuntu.com/ubuntu jammy InRelease' doesn't have the component 'bionic-updates/main' (component misspelt in sources.list?)

We are receiving several warnings as in the above while running sudo add-apt-repository "http://archive.ubuntu.com/ubuntu bionic-updates/main"

any suggestion is appreciated.


   
ReplyQuote
paulbuxton
(@paulbuxton)
Member Moderator
Joined: 11 months ago
Posts: 15
 

@memi 

Hi I beleive this this is because you are using Ubuntu 22.04, the requirements for the NCSDK are 18.04 or 20.04 (jammy indicates the Ubuntu version is Jammy Jellyfish which is the codename for Ubuntu22.04).

 


   
RCWO reacted
ReplyQuote
Memi
 Memi
(@memi)
Active Member
Joined: 2 years ago
Posts: 12
 

@paulbuxton  Thank you for the explanation. we suspected the version problem, but wanted to give it a try since the Tutorial mentions "Ubuntu Development Platform
x86-64 PC with a minimum 4GB RAM running Ubuntu 18.04 with a Micro SD Card slot (or USB connection to a Micro SD Card Adapter)", but 20.04 also works . why not give it a try with 22.04 :).

We will go back to 20.04. But,  just to clarify, from your explanation we conclude the warnings are not to be ignored. they are indeed problem. Please confirm.

Many thanks.


   
RCWO reacted
ReplyQuote
paulbuxton
(@paulbuxton)
Member Moderator
Joined: 11 months ago
Posts: 15
 

Yes those will likely cause a problem in addition I am told by the NCSDK team that there are other less obvious issues that pop up when using Ubuntu 22.04 I recently downgraded my own installation because of this.

There is an intention to update to a more up to date Ubuntu and drop 18.04 (as it is 4 years old now!), but I don't have any information on when that will be.


   
Memi reacted
ReplyQuote
Page 1 / 2