FoRUmS

v4l2 error sintax  

 

PandoraDC
(@pandoradc)
Active Member
Joined: 7 months ago
Posts: 5
21/04/2022 2:04 am  

When I try to execute the gst-launch-1.0 commands I got an error in syntax for the capture, and the video is not accessible for rtp command. I am using a C525 Logitech camera. Do you have similar issues?
I tried other commands available on the Internet without the gst-launch-1.0 and they catch images.


ReplyQuote
paulbuxton
(@paulbuxton)
Member Moderator
Joined: 7 months ago
Posts: 13
21/04/2022 10:14 am  

Hi,

 

I haven't seen that particular error. There are some known issues with the Pumpkin board regarding USB which can cause some problems, specifically there can be issues if you have multiple USB devices. Can you confirm if you are connecting to the board using SSH, or are you using a USB Keyboard as well as the Webcam?

 

Also can you confirm that you have installed the Firmware update to the boards which is the link below the teachin materials download here.

Edge AI Teaching Materials V1.0 (Beat Test) Beta Test Download - Imagination University Programme (imgtec.com)

Paul


ReplyQuote
luispimo
(@luispimo)
Member Moderator
Joined: 2 years ago
Posts: 16
21/04/2022 5:14 pm  

@pandoradc 

Could you post the exact command and its output?

Regards,

Luis


ReplyQuote
PandoraDC
(@pandoradc)
Active Member
Joined: 7 months ago
Posts: 5
21/04/2022 9:13 pm  

The error was solved. I added extra space in my command and that triggers the error. In addition, I tested with old IP, which was the cause of no video streaming in my test. Moreover, the recommended command in the manual has an argument written as ...framewrate=30/1"..., I think is a typo error for ...framerate=30/1", both command versions work.


RCWO and paulbuxton liked
ReplyQuote
luispimo
(@luispimo)
Member Moderator
Joined: 2 years ago
Posts: 16
22/04/2022 8:27 am  

@pandoradc 

You are right "framewrate" is a typo.

Thanks

Regards

Luis


RCWO liked
ReplyQuote