Notifications
Clear all

help with uploading elf file to fpga

 

(@Anonymous 14934)
Active Member Guest
Joined: 9 months ago
Posts: 11
Topic starter  

I'm following the getting started guide for the rvfpga course appendix a.

My problem is, after i start the telnet connection, when i try to load the elf file i receive the message: couldn't open LedsSwitches.elf.

I tried changing the permitions of the elf file but nothing changed. I also had to change the file swervolf_nexys_debug.cfg (path:/src/OtherSources/ConfigFiles/swervolf_nexys_debug.cfg) because the command riscv set_prefer_sba on gives an error. I think its because in the new version of open ocd this command no longer exists, but im not sure.

 

Any idea how i could fix this issue?

 

thx.


   
QuoteSolved
dchaver
(@dchaver)
Member Admin
Joined: 3 years ago
Posts: 70
 

Hi,

As you say file swervolf_nexys_debug.cfg needs to be changed by commenting the following command:

riscv set_prefer_sba

I've just tested Appendix A up to the LedsSwitches example and it's worked ok for me. Can you please take a look at the following video? It illustrates the process in my computer.

      https://drive.google.com/file/d/1sbmi-JuCWsQzLSJaW_Lf2yebDojzNZfj/view?usp=drive_link

Are you sure you are following the exact same steps described in the Appendix? Can you try again?

Please let us know if you can resolve the problem.

Thanks

Best regards

Dani


   
ReplyQuote